CVE-2026-70654

Publication date 20 August 2026

Last updated 3 November 2026


Ubuntu priority

Description

libvips is a fast image processing library with low memory needs. Prior to version 8.18.3, applications that define unusual custom libvips sources and use them to process untrusted uncompressed PPM images can trigger a max/min error in vips_source_read_to_memory in libvips/iofuncs/source.c. The function uses VIPS_MAX instead of VIPS_MIN when selecting the remaining read size, allowing up to 4032 bytes to be written beyond the allocated heap buffer and causing memory corruption or a process crash. This issue is fixed in version 8.18.3.

Status

Package Ubuntu Release Status
vips 26.10 stonking
Not affected
26.04 LTS resolute
Fixed in 8.18.0-1ubuntu0.1~esm2
24.04 LTS noble
Fixed in 8.15.1-1.1ubuntu0.1~esm2
22.04 LTS jammy
Fixed in 8.12.1-1ubuntu0.1~esm3
20.04 LTS focal
Fixed in 8.9.1-2ubuntu0.1~esm2
18.04 LTS bionic
Not affected
16.04 LTS xenial
Not affected

Get expanded security coverage with Ubuntu Pro

Reduce your average CVE exposure time from 98 days to 1 day with expanded CVE patching, ten-years security maintenance and optional support for the full stack of open-source applications. Free for personal use.

Get Ubuntu Pro 30-day free trial

Severity score breakdown

CVSS version: CVSS v4.0

Base score 5.8 · Medium

Vector: CVSS:4.0/AV:L/AC:H/AT:P/PR:L/UI:N/VC:N/VI:L/VA:H/SC:N/SI:N/SA:N


Access our resources on patching vulnerabilities